0
09356748889

خطاهای امنیتی کشف شده در وردپرس (May 2021)

خطاهای امنیتی کشف شده در وردپرس (May 2021)

خطاهای امنیتی کشف شده در وردپرس (May 2021)

در ماه May 2021 مصادف با اردیبهشت ۱۴۰۰ یک آسیب پذیری در سطح هسته وردپرس و تعدادی آسیب پذیری هم در پلاگین‌ها و تم‌های وردپرسی شناسایی شده است که در ادامه جزییات آن را معرفی می‌کنیم.

آسیب پذیری های کشف شده در هسته وردپرس

خوشبختانه آسیب‌پذیری‌های کشف شده در هسته زیاد نیستند و فقط کافی است به مورد زیر توجه کنید.

آسیب پذیری Object Injection

در تمامی نسخه‌های وردپرس از ۳.۷ تا ۵.۷.۱ ، از یک کتابخانه آسیب پذیر PHPMailer استفاده شده است که این کتابخانه دارای آسیب پذیری PHP Object Injection می‌باشد. برای رفع این آسیب پذیری، کتابخانه PHPMailer از نسخه ۶.۴.۰ به ۶.۴.۱ آپدیت شده است.

نسخه‌های وردپرس آسیب پذیر: ۳.۷ تا ۵.۷.۱

آسیب پذیری های کشف شده در پلاگین‌های وردپرس

اگر در حال استفاده از هر کدام از این افزونه‌هایی هستید که در ادامه معرفی می‌کنیم، باید هر چه سریعتر اقدامات گفته شده را انجام دهید و راه نفوذ و لو رفتن اطلاعات‌تان را ببندید.

 

آسیب پذیری XSS در پلاگین FooGallery

در این پلاگین، بخش Custom CSS به درستی sanitize و اعتبارسنجی نمی‌شود و این موضوع منجر آسیب پذیری Stored XSS می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰.۳۵ و ما قبل آن

آسیب پذیری SQL Injection در پلاگین Yes/no Chart

پارامتر shortcode در این پلاگین به درستی sanitize نمی‌شود و کاربران با سطح دسترسی متوسط (مانند contributor و بالاتر) امکان اجرای حمله Blind SQL Injection را خواهد داشت.

نسخه‌های آسیب پذیر در این پلاگین: ۱.۰.۱۲ و ما قبل آن

آسیب پذیری Open Redirect در پلاگین The Plus Addons for Elementor Page Builder

این پلاگین یک پارامتر redirect را به درستی اعتبارسنجی نمی‌کند و با یک آدرس URL ساختگی می‌‎توان کاربران سایت را فریب داد تا به جایی دیگر redirect شوند.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۱.۱۰ و ما قبل آن

آسیب پذیری Arbitrary Reset Password Email Sending در پلاگین The Plus Addons for Elementor Page Builder

این پلاگین بررسی نمی‌کند کاربری که درخواست reset password کرده است، همان کاربر اصلی و قانونی است یا خیر. ترکیب این آسیب پذیری و همچنین آسیب پذیری Open Redirect که گفته شد، منجر به Account Takeover می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۱.۱۱ و ما قبل آن

آسیب پذیری XSS در پلاگین The Plus Addons for Elementor Page Builder

عملیات AJAX در بخش theplus_more_post به درستی برخی از فیلدها را sanitize نمی‌کند و این موضوع باعث آسیب پذیری Reflected XSS می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۱.۱۲ و ما قبل آن

آسیب پذیری PHAR Deserialization در پلاگین NinjaFirewall

این پلاگین یک نقص امنیتی از نوع PHAR Deserialization دارد که با استفاده از آن، یک کاربر با دسترسی ادمین می‌تواند کدهای دلخواه خود را بر روی remote host اجرا کند.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۳.۴ و ما قبل آن

آسیب پذیری SQL Injection در پلاگین Xllentech English Islamic Calendar

هنگام پاک کردن یک تاریخ در این پلاگین، پارامترهای year_number و month_number به درستی sanitize یا اعتبار سنجی نمی‌شوند و این موضوع منجر به حمله SQL Injection خواهد شد.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۶.۸ و ما قبل آن

آسیب پذیری SQL Injection در پلاگین Side Menu

Functionality مربوط به menu delete در این پلاگین برای کاربران با سطح دسترسی ادمین در دسترس است و به دلیل عدم sanitization یا اعتبارسنجی مناسب، می‌توانند با استفاده از آن حمله SQL Injection را انجام دهند.

نسخه‌های آسیب پذیر در این پلاگین: ۳.۱.۵ و ما قبل آن

 

آسیب پذیری XSS در پلاگین Stock in & out

این پلاگین دارای یک search functionality است که در آن پارامتر srch به درستی اعتبارسنجی و sanitize نمی‌شود و این موضوع منجر به آسیب پذیری Reflected XSS خواهد شد.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری SQL Injection در پلاگین Sendit WP Newsletter

صفحه lists-management که برای کاربران administrator در دسترس است، پارامتر id_lista را به درستی sanitize و اعتبارسنجی نمی‌کند و این موضوع منجر به حمله Blind SQL Injection می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری XSS در پلاگین Visitors

پلاگین Visitors دارای آسیب پذیری Stored XSS می‌باشد. این پلاگین user agent کاربران را بدون اعتبارسنجی و encoding در صفحه مدیریت وردپرس نمایش می‌دهد.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری Arbitrary Plugin Activation در پلاگین Simple 301 Redirects by BetterLinks

در این پلاگین، به دلیل ضعف و عدم بررسی nonce ها در یکی از عملیات‌های AJAX، این امکان را برای کاربران authenticate شده فراهم می‌کند تا بتوانند پلاگین‌های نصب شده دلخواه خود را بر روی سایت فعال کنند.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰.۴ و ما قبل آن

آسیب پذیری Arbitrary Plugin Installation در پلاگین Simple 301 Redirects by BetterLinks

در این پلاگین، به دلیل ضعف و عدم بررسی nonce ها در یکی از عملیات‌های AJAX، این امکان را برای کاربران authenticate شده فراهم می‌کند تا بتوانند پلاگین‌های دلخواه خود را بر روی سایت نصب کنند.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰.۴ و ما قبل آن

آسیب پذیری Redirect Import Unauthenticated در پلاگین Simple 301 Redirects by BetterLinks

function مربوط به import_data در این پلاگین، به دلیل ضعف در بررسی nonce، به هر کاربری اجازه می‌دهد تا مجموعه‌ای از ریدارکت سایت‌ها را import کند.

 

 

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰.۴ و ما قبل آن

آسیب پذیری Unauthenticated Redirect Export در پلاگین Simple 301 Redirects by BetterLinks

function مربوط به export_data در این پلاگین، به دلیل ضعف در بررسی nonce، به هر کاربری اجازه می‌دهد تا ریدایرکت‌های یک سایت را export کند.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰.۴ و ما قبل آن

آسیب پذیری XSS در پلاگین Gallery From Files

این پلاگین یک قابلیت آپلود تصویر دارد؛ اما نام فایل‌ها هنگام نمایش در پیغام خطا به دلیل داشتن یک extension نامعتبر، به درستی sanitize نمی‌شوند و این موضوع منجر به آسیب پذیری Reflected XSS خواهد شد.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری RCE در پلاگین Gallery From Files

قابلیت آپلود فایل در این پلاگین، به درستی extenstion های مجاز را بررسی نمی‌کند و همین موضوع باعث می‌شود تا مهاجم بتواند فایل مخربی با پسوند .php4 آپلود کند و قابلیت اجرای دستور بر روی سرور را داشته باشد.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری Arbitrary Product Comment در پلاگین Multivendor Marketplace Solution for WooCommerce

این پلاگین به درستی CSRF را هنگام ذخیره نظر محصول بررسی نمی‌کند؛ در نتیجه مهاجم می‌تواند با تغییر پارامتر current_user_id ، نظر دلخواه خود را با نام یک کاربر دیگر ارسال کند.

نسخه‌های آسیب پذیر در این پلاگین: ۳.۷.۴ و ما قبل آن

آسیب پذیری XSSدر پلاگین Cookie Law Bar

این پلاگین به درستی تنظیمات Bar Message را sanitize نمی‌کند و این موضوع منجر به آسیب پذیری Stored XSS می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری File Upload در پلاگین SP Project & Document Manager

این پلاگین قابلیت آپلود فایل را در اختیار کاربران قرار می‌دهد. اگرچه که موارد امنیتی جهت جلوگیری از آپلود فایل‌های PHP و سایر فایل‌هایی که بتوانند در سرور اجرا شوند در این پلاگین رعایت شده است، اما با این حال همچنان فایل‌های PHP با تغییر پسوند آنها از “php” به “pHP” قابلیت آپلود شدن را دارند

نسخه‌های آسیب پذیر در این پلاگین: ۴.۲۲ و ما قبل آن

آسیب پذیری XSS در پلاگین Easy Preloader

این پلاگین فیلدهای تنظیمات خود را sanitize نمی‌کند و این موضوع منجر به آسیب پذیری Stored XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری XSS در پلاگین iFlyChat – WordPress Chat

این پلاگین تنظیمات APP ID را sanitize نمی‌کند و این موضوع منجر به آسیب پذیری Stored XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری SQL Injection در پلاگین Video Embed

پارامتر id در یکی از صفحات این پلاگین به درستی sanitize و اعتبارسنجی نمی‌شود و به کاربران با سطح دسترسی پایین امکان اجرای حمله SQL Injection را می‌دهد.

نسخه های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری SQL Injection در پلاگین FlightLog

در این پلاگین پارامترهای مختلف از نوع POST به طور صحیح sanitize و اعتبارسنجی نمی‌شود و این موضوع منجر به آسیب پذیری SQL Injection می‌شود که توسط کاربران با سطح دسترسی editor و administrator قابل اجرا خواهد بود.

نسخه های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری SQL Injection در پلاگین WP Statistics

این پلاگین از تابع esc_sql استفاده می‌کند که به طور صحیح پیاده‌سازی نشده است و همین موضوع منجر به آسیب پذیری SQL Injection می‌شود. همچنین صفحه‌ای که باید تنها برای administrator در دسترس باشد، برای تمامی کاربران سایت قابل دسترس است.

نسخه های آسیب پذیر در این پلاگین: ۱۳.۰.۸ و ما قبل آن

آسیب پذیری XSS در پلاگین WP Prayer

این پلاگین قابلیت آن را دارد که prayers/praises های درخواست شده را ذخیره می‌کند و آن‌ها را در سایت لیست می‌کند. هر کاربر وردپرس با هر نقشی می‌تواند این درخواست را پر و ارسال کند. این فرم شامل چند بخش می‌باشد. این فیلدها از اعتبارسنجی مناسب استفاده نمی‌کنند و می‌توان در آن‌ها پیلودهای XSS تزریق کرد که منجر به حمله Stored XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: ۱.۶.۲ و ما قبل آن

آسیب پذیری PHP Object Injection در پلاگین CM Registration Pro

این پلاگین از یک کتابخانه منسوخ شده استفاده می‌کند که این کتابخانه دارای آسیب پذیری PHP Object Injection می‌باشد. نسخه رایگان این پلاگین از این کتابخانه استفاده نمی‌کند و این آسیب پذیری در نسخه رایگان این پلاگین وجود ندارد.

نسخه های آسیب پذیر در این پلاگین: ۳.۲.۱ و ما قبل آن

آسیب پذیری XSS و XFS در پلاگین Instant Images WordPress Plugin

پارامترهای unsplash_download_w و unsplash_download_h در این پلاگین به درستی اعتبارسنجی نمی‌شوند. این پارامترها تنها به صورت client side اعتبارسنجی شده و این موضوع منجر به آسیب پذیری Stored XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: ۴.۴.۰.۱ و ما قبل آن

آسیب پذیری XSS در پلاگین Smooth Scroll Page Up/Down Buttons

این پلاگین تنظیمات خود، مانند psb_distance، psb_buttonsize، psb_speed را به درستی sanitize و اعتبارسنجی نمی‌کند. این موضوع به کاربران با سطح دسترسی بالا مانند (admin) امکان اجرای حمله Stored XSS را می‌دهد.

نسخه های آسیب پذیر در این پلاگین: ۱.۴ و ما قبل آن

آسیب پذیری XSS در پلاگین Funnel Builder by CartFlows

این پلاگین در تنظیمات خود facebook_pixel_id و google_analytics_id را به درستی sanitize نمی‌‎کند و به کاربران با سطح دسترسی بالا امکان تزریق کدهای مخرب را می‌دهد. این آسیب پذیری از نوع Stored XSS است.

نسخه های آسیب پذیر در این پلاگین: ۱.۶.۱۳ و ما قبل آن

آسیب پذیری Authenticated RCE در پلاگین WP Super Cache

پارامترهای $wp_cache_debug_ip، $wp_super_cache_front_page_text، $cache_scheduled_time، $cached_direct_pages در این پلاگین به دلیل اینکه کاراکترهای “$” و “\n” را به عنوان ورودی قبول می‌کند، دارای آسیب پذیری RCE هستند. این موضوع به دلیل عدم رفع مشکل به طور صحیح مربوط به CVE-2021-24209 است.

 

نسخه های آسیب پذیر در این پلاگین: ۲.۴ و ما قبل آن

آسیب پذیری Arbitrary File Upload در پلاگین External Media

عملیات AJAX مربوط به بخش wp_ajax_upload_remote_file دارای آسیب پذیری arbitrary file upload است و هر کاربر احرازهویت شده امکان اجرای آن را خواهد داشت.

نسخه های آسیب پذیر در این پلاگین: ۱.۰.۳۴ و ما قبل آن

آسیب پذیری XSS در پلاگین Weekly Schedule

ورودی Schedule Name در این پلاگین به درستی ورودی‌ها را اعتبارسنجی نمی‌کند و به کاربران احرازهویت شده امکان تزریق کدهای مخرب جاوا اسکریپت را می‌دهد. این آسیب پذیری از نوع Stored XSS است.

نسخه های آسیب پذیر در این پلاگین: ۳.۴.۳ و ما قبل آن

آسیب پذیری XSS در پلاگین Photo Gallery

این پلاگین به درستی gallery title را sanitize نمی‌کند و به کاربران با سطح دسترسی بالا امکان تزریق پیلودهای XSS را در این بخش می‌دهد که این کد مخرب هنگامی‌که کاربر دیگری gallery list را مشاهده می‌کند، trigger می‌شود.

نسخه های آسیب پذیر در این پلاگین: ۱.۵.۶۷ و ما قبل آن

آسیب پذیری XSS در پلاگین LifterLMS

این پلاگین به درستی coupon code را هنگام نمایش پیغام خطا در خروجی بررسی نمی‌کند و این موضوع منجر به آسیب پذیری Reflected XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: ۴.۲۱.۱ و ما قبل آن

آسیب پذیری XSS در پلاگین LifterLMS

بخش state در صفحه ویرایش پروفایل به درستی sanitize نمی‌کند و این موضوع به کاربران با سطح دسترسی پایین مانند students این امکان را می‌دهد تا با اجرای حمله XSS بتواند سطح دسترسی خود را ارتقا دهد، هنگامی‌که یک کاربر ادمین پروفایل خود را نگاه می‌کند.

نسخه های آسیب پذیر در این پلاگین: ۴.۲۱.۱ و ما قبل آن

آسیب پذیری RCE در پلاگین All in One SEO Pack

این پلاگین به کاربران با سطح دسترسی aioseo_tools_settings اجازه اجرای دستور را می‌دهد. همچنین کاربران می‌توانند تنظیمات پلاگین را با آپلود یک فایل backup.ini در بخش “Tool > Import/Export” بازگردانی کنند.

نسخه های آسیب پذیر در این پلاگین: ۴.۱.۰.۲ و ما قبل آن

آسیب پذیری مربوط به XSS در پلاگین ReDi Restaurant Reservation

این پلاگین قابلیت restaurant reservation را فراهم می‌کند. این رزرواسیون‌ها ذخیره می‌شوند و می‌توانند در یک صفحه Upcoming لیست شود. هر کاربری می‌تواند این فرم را پر کند. این فرم دارای یک بخش به نام comment است که به درستی اعتبارسنجی در آن انجام نمی‌شود و این موضوع منجر به آسیب پذیری Stored XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: ۲۱.۰۴۲۶ و ما قبل آن

آسیب پذیری XSS در پلاگین Simple Giveaways

پارامترهای method و share در این پلاگین sanitize و اعتبارسنجی نمی‌شوند و این مشکل باعث آسیب پذیری Reflected XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: ۲.۳۶.۲ و ما قبل آن

آسیب پذیری Unauthorized AJAX call در پلاگین ThemeHigh WooCommerce Wishlist and Comparison

برخی از عملیات‌های AJAX در این پلاگین فاقد بررسی CSRF و authorization است و به مهاجمان این اجازه را می‌دهد که برخی اقدامات مانند reset یا تغییر تنظیمات پلاگین را انجام دهند.

نسخه های آسیب پذیر در این پلاگین: ۱.۰.۵ و ما قبل آن

آسیب پذیری CSRF Bypass در پلاگین Zlick Paywall

این پلاگین دارای نقص منطقی CSRF است که به مهاجمان اجازه دور زدن CSRF را می‌دهد.

نسخه های آسیب پذیر در این پلاگین: ۲.۲.۲ و ما قبل آن

آسیب پذیری XSS در پلاگین Autoptimize

در تنظیمات این پلاگین sanitization و escaping پیاده سازی نشده است و به کاربران با سطح دسترسی بالا امکان حمله Stored XSS را می‌دهد.

نسخه های آسیب پذیر در این پلاگین: ۲.۸.۴ و ما قبل آن

آسیب پذیری XSS در پلاگین Ultimate Member

هنگام ایجاد لینک برای ویرایش پروفایل کاربر، query string به درستی sanitize، اعتبارسنجی یا encode نمی‌شود و این نقص امنیتی منجر به آسیب پذیری Reflected XSS می‌شود. برای اجرای این آسیب پذیری نیاز به داشتن نام کاربری شخص مورد هدف است و مهاجم باید کاربر لاگین شده را فریب دهد تا یک لینک مخرب را باز کند.

نسخه های آسیب پذیر در این پلاگین: ۲.۱.۲۰ و ما قبل آن

آسیب پذیری PHP Object Injection در پلاگین UltimateWoo

در این پلاگین از یک کتابخانه‌ای که نسخه آن منسوخ شده و آسیب پذیر است استفاده می‌کند و دارای آسیب پذیری PHP Object Injection می‌باشد.

نسخه های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری XSS در پلاگین DSGVO All in one for WP

عملیات AJAX مربوط به بخش dsgvoaio_write_log در این پلاگین برخی از پارامترهای از نوع POST را قبل از نمایش آنها در صفحه لاگ sanitize یا escape نمی‌کند و این موضوع باعث آسیب پذیری Stored XSS می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۴.۰ و ما قبل آن

آسیب پذیری Unauthenticated License Change در پلاگین Leads-5050 Visitor Insights

عملیات AJAX مربوط به بخش leads5050_set_license به هر کاربری این امکان را می‌دهد که license دلخواه خود را در تنظیمات این پلاگین قرار دهد.

نسخه های آسیب پذیر در این پلاگین: ۱.۱.۰ و ما قبل آن

آسیب پذیری XSS در پلاگین PickPlugins Product Slider for WooCommerce

قابلیت slider import search در تنظیمات این پلاگین پارامتر keyword را به درستی sanitize نمی‌کند و این موضوع منجر به آسیب پذیری Reflected XSS می‌شود.

نسخه های آسیب پذیر در این پلاگین: ۱.۱۳.۲۲ و ما قبل آن

آسیب پذیری XSS در پلاگین Target First Plugin

مهاجم می‌تواند مقدار license key را از طریق پارامتر weeWzKey تغییر دهد. مقدار ورودی sanitize نمی‌شود، همچنین authentication و credential ها نیز توسط این پلاگین بررسی نمی‌شوند. در نهایت این مشکلات امنیتی منجر به آسیب پذیری Stored XSS می‌شود.

 

نسخه های آسیب پذیر در این پلاگین: ۱.۰ و ما قبل آن

آسیب پذیری XSS در پلاگین Hana Flv Player

این پلاگین در بخش Default Skin خود دارای آسیب پذیری Stored XSS می‌باشد.

نسخه های آسیب پذیر در این پلاگین: ۳.۱.۳ و ما قبل آن

آسیب پذیری CSRF در پلاگین Parcel Tracker eCourier

این پلاگین به درستی CSRF را بررسی نمی‌کند و به مهاجم اجازه می‌دهد تا با استفاده از این آسیب پذیری یک کاربر ادمین را فریب داده و تنظیمات پلاگین را تغییر دهد.

نسخه های آسیب پذیر در این پلاگین: ۱.۰.۲ و ما قبل آن

آسیب پذیری CSRF در پلاگین Ship To Ecourier

این پلاگین به درستی CSRF را بررسی نمی‌کند و به مهاجم اجازه می‌دهد تا با استفاده از این آسیب پذیری یک کاربر ادمین را فریب داده و تنظیمات پلاگین را تغییر دهد.

نسخه های آسیب پذیر در این پلاگین: ۱.۰.۲ و ما قبل آن

آسیب پذیری SQL Injection در پلاگین Spam protection, AntiSpam, FireWall by CleanTalk

تابع update_log که در مسیر lib/Cleantalk/ApbctWP/Firewall/SFW.php وجود دارد، شامل یک کوئری آسیب پذیر است که می‌تواند از طریق هدر User-Agent تزریق شود که در نهایت منجر به آسیب پذیری Blind SQL Injection می‌شود.

نسخه‌های آسیب پذیر در این پلاگین: ۵.۱۵۳.۴ و ما قبل آن

آسیب پذیری XSS در پلاگین WP Customer Reviews

این پلاگین برخی از تنظیمات خود را sanitize نمی‌کند؛ در نتیجه به کاربران با سطح دسترسی بالا مانند administrator امکان اجرای کدهای مخرب جاوا اسکریپت را می‌دهد. این آسیب پذیری از نوع Stored XSS بوده و کدهای مخرب در صفحاتی که review ها فعال باشند اجرا خواهند شد.

نسخه‌های آسیب پذیر در این پلاگین: ۳.۵.۶ و ما قبل آن

آسیب پذیری XSS در پلاگین Hotjar Connecticator

در بخش textarea مربوط به hotjar script این پلاگین، آسیب پذیری Stored XSS وجود دارد. به دلیل وجود CSRF nonce که به طور صحیح توسط سرور اعتبارسنجی می‌شود، این آسیب پذیری فقط توسط کاربران administrator قابل بهره‌برداری است.

نسخه‌های آسیب پذیر در این پلاگین: تا این لحظه تمامی نسخه‌های این پلاگین آسیب پذیرند.

آسیب پذیری Arbitrary User Locale Change در پلاگین Simple Admin Language Change

در عملیات AJAX مربوط به بخش change_user_locale در این پلاگین، csrf به درستی بررسی نمی‌شود. همچنین این پلاگین در نسخه‌های پایین‌تر از ۲.۰.۰ دارای آسیب پذیری IDOR است و به مهاجم اجازه می‌دهد تا مکان یک کاربر دیگر را تغییر دهد.

نسخه‌های آسیب پذیر در این پلاگین: ۲.۰.۲ و ما

آسیب پذیری XSS در تم JNews

در این تم پارامتر cat_id در درخواست POST به درستی sanitize نمی‌شود و باعث آسیب پذیری Reflected XSS می‌گردد.

نسخه‌های آسیب پذیر در این تم: ۸.۰.۶ و ما قبل آن

آسیب پذیری XSS و XFS در تم Car Repair Services

پارامتر search در این تم به درستی sanitize نمی‌شود و این موضوع منجر به آسیب پذیری Reflected XSS می‌شود.

نسخه های آسیب پذیر در این تم: ۴.۰ و ما قبل آن

آسیب پذیری XSS در تم Mediumish

پارامتر search در این تم به درستی sanitize نمی‌شود و این موضوع منجر به آسیب پذیری Reflected XSS می‌شود.

نسخه های آسیب پذیر در این تم: تا این لحظه تمامی نسخه‌های این تم آسیب پذیرند.

چند آسیب پذیری XSS و XFS در تم Listeo

این تم برخی از پارامترها را در صفحاتی مانند Search، Booking Confirmation و Personal Message به درستی sanitize نمی‌کند و این نقص امنیتی منجر به آسیب پذیری XSS می‌شود.

نسخه های آسیب پذیر در این تم: ۱.۶.۱۱ و ما قبل آن

چند آسیب پذیری IDOR در تم Listeo

در این تم بررسی نمی‌شود که آیا پست یا صفحه و همچنین رزروی که درخواست حذف آن آمده است، آیا درخواست آن از طرف همان کاربر بوده یا خیر و این موضوع باعث می‌شود تا هر کاربری بتواند صفحه یا پست یا رزرو دلخواه خود را حذف کند.

نسخه های آسیب پذیر در این تم: ۱.۶.۱۱ و ما قبل آن

آسیب پذیری XSS و XFS در تم Bello

این تم پارامتر post_excerpt را هنگام نمایش در صفحه shop/my-account/bello-listing-endpoint به درستی sanitize نمی‌کند و این موضوع منجر به آسیب پذیری XSS می‌شود.

نسخه های آسیب پذیر در این تم: ۱.۶.۰ و ما قبل آن

آسیب پذیری XSS و XFS در تم Bello

این تم پارامترهای listing_list_view, bt_bb_listing_field_my_lat, bt_bb_listing_field_my_lng, bt_bb_listing_field_distance_value, bt_bb_listing_field_my_lat_default, bt_bb_listing_field_keyword, bt_bb_listing_field_location_autocomplete, bt_bb_listing_field_price_range_from و bt_bb_listing_field_price_range_to که در صفحه listing وجود دارد را به درستی sanitize نمی‌کند و باعث آسیب پذیری XSS می‌شود.

نسخه های آسیب پذیر در این تم: ۱.۶.۰ و ما قبل آن

آسیب پذیری SQL Injection در تم Bello

پارامتر های bt_bb_listing_field_price_range_to, bt_bb_listing_field_now_open, bt_bb_listing_field_my_lng, listing_list_view و bt_bb_listing_field_my_latقبل از استفاده در کوئری‌های دیتابیس به درستی sanitize نمی‌شوند و این موضوع منجر به حمله Blind SQL Injection می‌شود که هر کاربری قادر به اجرای آن خواهد بود.

نسخه های آسیب پذیر در این تم:  ۱.۶.۰ و ما قبل آن

آسیب پذیری XSS در تم Goto

این تم پارامتر formvalue که از نوع JSON POST هست را در عملیات AJAX مربوط به بخش tl_filter به درستی sanitize نمی‌کند و این موضوع منجر به آسیب پذیری XSS Reflected می‌شود.

نسخه های آسیب پذیر در این تم: ۲.۱ و ما قبل آن

 

آسیب پذیری‌های کشف شده در تم‌های وردپرس

در این بخش با قالب‌های وردپرس سروکار داریم. اگر قالب سایت‌تان یکی از موارد زیر است، اقدامات لازم جهت ارتقاء امنیت آن را فوراً انجام دهید.

 

جمع‌بندی

اگر می‌خواهید سایت‌ وردپرسی‌تان دچار مشکلات مختلف امنیتی نشود، حتماً باید مواردی که در این مقاله به آن‌ها اشاره کرده‌ایم را مدنظر داشته باشید.

اگر از هرکدام از افزونه‌ها یا پلاگین‌هایی که بالاتر از آن‌ها نام بردیم و به نقص‌های‌شان اشاره کردیم، استفاده می‌کنید، سریعاً آن‌ها را به‌روزرسانی کنید تا سایت‌تان به خطر نیفتد!

ارسال دیدگاه

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *